Разработчики jQuery, одной из самых популярных библиотек JavaScript, объявили о работе над релиз-кандидатом версии 3.0. Когда она выйдет в окончательном варианте, то станет единственной, поддерживаемой официально. Для веток 1.12 и 2.2 еще какое-то время планируется выпускать критические обновления, но новые функции разрабатываться не будут. Поддержка версий Internet Explorer с 6 по 8 включительно в jQuery 3.0 не предусмотрена.

По словам разработчиков, в новой версии библиотеки есть ряд критических изменений, но обновление существующего кода согласно требованиям jQuery 3.0 трудности не составит. Обнаружить проблемы совместимости поможет плагин jQuery Migrate 3.0-rc.

Среди новшеств версии 3.0 — поддержка механизма отложенных и асинхронных вычислений Promises, определенного в стандарте ECMAScript 2015; существенное ускорение работы некоторых селекторов; а также интерфейс requestAnimationFrame, позволяющий воспроизводить анимации более плавно, с меньшей нагрузкой на процессор и батарею. Неверные вызовы методов вроде window.offset(), раньше «молчаливо» не выполнявшиеся, теперь будут возвращать ошибку.

По данным W3Techs, сегодня библиотека jQuery, которой в январе исполнилось 10 лет, используется на 70,2% сайтов из первой десятки миллионов по посещаемости.

Поделитесь материалом с коллегами и друзьями