До недавнего времени сообщение на ее официальном сайте гласило: "Всего одна дыра за 10 лет!" Отныне, однако, на сайте сообщается уже о двух дырах. Ошибка возникает из-за порчи памяти процедурой mbuf при обработке фрагментированных пакетов ICMP6, что может привести к сбою ядра или открытию возможности запуска постороннего кода с привилегиями уровня ядра. Наличие ошибки подтверждено в версиях OpenBSD 3.1 и 4.0, но возможно, она присутствует и в других. Разработчики OpenBSD выпустили соответствующую заплату. Следует отметить, что специалистам Core Security пришлось потрудиться, чтобы убедить разработчиков в серьезности ошибки, которая на первый взгляд способна лишь вызвать останов системы, что не считается сбоем безопасности. В конце концов в Core написали образец эксплойта, демонстрирующего возможность запуска постороннего кода в контексте ядра, и только после этого команда OpenBSD признала ошибку в качестве уязвимости.

Поделитесь материалом с коллегами и друзьями